从源码编译安装

# 下载Swoolewget http://pecl.php.net/get/swoole-4.5.2.tgztar zxvf swoole4.5.2.tgzcd swoole4.5.2# 安装相关依赖yum y install gcc gccc++ autoconf pcredevel make# 编译安装,会自动放到默认的扩展目录phpize./configure enableopenssl enablehttp2make && sudo make install# 定位配置文件路径php i | grep php.ini# 或者php ini# 或者locate php.ini# 打开配置文件vim yourpath/php.ini# php.ini 中启用扩展extension=swoole.so# 查看是否安装成功php ri swoole# 或者(-m有可能不会出现Swoole扩展信息)php m# 或者<?php phpinfo();

PECL 安装

pecl install swoole# php.ini 中启用扩展extension=swoole.so

从源码编译升级

步骤与从源码编译安装一致。

不需要卸载或者删除旧版本 Swoole,安装过程会覆盖旧版本。

PECL 升级

pecl upgrade swoole

Docker 官方镜像

https://hub.docker.com/r/phpswoole/swoole

发表回复

您的电子邮箱地址不会被公开。